SimpleBackups - Incorrect emails was sent to multiple accounts – Incident details
Report an issue
Get updates
Email
SMS
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
Incorrect emails was sent to multiple accounts
Resolved
Operational
Started about 1 month ago
Lasted 7 days
Affected
Cloudflare Pages
Updates
Resolved
January 11, 2025 at 10:27 AM
Resolved
January 11, 2025 at 10:27 AM
This incident has been resolved.
Investigating
January 04, 2025 at 8:27 AM
Investigating
January 04, 2025 at 8:27 AM
We are currently investigating this incident.